Subbly services unavailable due to Cloudflare outage

Incident Report for Subbly

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 12:18 UTC

Identified

We are currently experiencing a service disruption affecting multiple parts of the Subbly platform. The outage is caused by a widespread Cloudflare issue impacting connectivity and availability across multiple services globally. Because our infrastructure relies on Cloudflare for routing and security, this external incident is directly affecting Subbly’s uptime.
Posted Nov 18, 2025 - 12:09 UTC
This incident affected: Core Subbly Services (Admin, Checkout) and API.