Website Builder Issue

Incident Report for Subbly

Resolved

The issue has been identified and resolved, it is now possible to create new sites again. We apologize for any inconvenience caused.

We're continuing internal investigations to determine what caused the setting that affected this to change.
Posted Jul 08, 2025 - 17:26 UTC

Update

We are continuing to investigate this issue.
Posted Jul 07, 2025 - 21:07 UTC

Update

We are continuing to investigate this issue.
Posted Jul 07, 2025 - 21:05 UTC

Investigating

We're currently experiencing an issue with the website builder that prevents users from loading the new template. A fix is in progress and should be live within 24 hours. If you're a new subscriber affected by this, please contact our CS team for a trial extension. We apologize for the inconvenience.
Posted Jul 07, 2025 - 20:26 UTC
This incident affected: Website Builder & Hosting.