Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 12, 2022 - 05:15 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 12, 2022 - 05:07 UTC
Scheduled
We will be undergoing necessary maintenance during this time. These maintenance periods are how we continually improve Subbly’s reliability. We are planning 2 or 3 more maintenance periods over the next 2 months, and will make sure to inform you well in advance.