Problem was resolved. Everything is fully operational again. Sorry for the downtime.
Posted Mar 09, 2026 - 15:51 UTC
Monitoring
A fix has been deployed, we're still monitoring the problem. Website builder is accessible now.
Posted Mar 09, 2026 - 15:23 UTC
Identified
Root cause of the issue has been identified, we're waiting for the hosting partners to resolve for it. There's no ETA communicated at this point, we'll update once we have ETA for this to be resolved.
Posted Mar 09, 2026 - 15:01 UTC
Investigating
We're currently having problems with 3rd party hosting we're using to host projects made on the legacy website builder. Problem has been diagnosed and the hosting partners are actively working on resolving this. As a result of this, access to the legacy builder is revoked, but the sites are fully operational. We apologize for the inconvenience.
Posted Mar 09, 2026 - 15:00 UTC
This incident affected: Legacy Website Builder & Hosting.