SSL issues on Subbly.me domain
Incident Report for Subbly
Resolved
This has been fixed now, sorry for any inconvenience.
Posted Oct 21, 2021 - 16:30 UTC
Identified
We are aware of an issue with the subbly.me SSL, we are working on a fix just now.
Posted Oct 21, 2021 - 16:28 UTC
This incident affected: Website Builder & Hosting.