Some processes are temporarily delayed - We are working on it

Incident Report for Subbly

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 19:26 UTC

Identified

We’re currently seeing a delay in background processing, which may affect email deliverability, renewals, and how credit balances appear in your AI website builder.
Posted Nov 07, 2025 - 17:14 UTC
This incident affected: Core Subbly Services (Automations & Jobs, Emails & Communication).