Legacy website builder not loading (hosting unaffected)

Incident Report for Subbly

Resolved

After extensive testing and looking in the wrong places, after some reports came in about other strange behaviors, we realized that the issue was related to our security layer being too aggressive and blocking requests to our API. Security is a high priority for us, but so is reliability so it's unfortunate that we accidentally traded one off for the other in this instance. We have now since resolved this and we apologize for any inconveniences caused.
Posted Oct 17, 2025 - 05:02 UTC

Investigating

We’re currently investigating an issue affecting the Legacy Builder platform that is preventing customers from accessing the builder. All published websites remain live and fully operational. Updates will be provided as soon as more information becomes available.
Posted Oct 16, 2025 - 22:33 UTC
This incident affected: Legacy Website Builder & Hosting.