Customer support chat and email is unavailable
Incident Report for Subbly
Resolved
Chat widget is back and working as usual. Sorry for the inconveniences caused.
Posted Oct 30, 2023 - 16:33 UTC
Monitoring
Our support chat is now coming back online and we will be working to catch back up on tickets. We sincerely apologize for he inconvenience caused, we've already implemented measures to prevent this happening again, we know how important swift responses are to you and we strive to uphold a high quality and high speed response time. We are also going to review our backup channels and processes in case this does ever happen again. Thank you for your patience.
Posted Oct 30, 2023 - 15:08 UTC
Update
We are currently facing technical issues with our customer support chat and emails, we are working hard to bring them back online and expect it to take up to 24 hours.

👉 Got an urgent question or issue? Please use the dedicated chat on our facebook group: https://m.me/ch/AbZTz1gnOkU_HlcZ/ or our Discord chat: https://subb.ly/discord whichever you prefer.
Posted Oct 28, 2023 - 13:53 UTC
Identified
We are having issues with out support channels. Sorry for the inconvenience, we're working hard to bring them back online.
Posted Oct 28, 2023 - 13:52 UTC
This incident affected: Customer Support.